I can't upload a custom logo to my Newtek Cart

If you are trying to upload a custom image using the admin interface for Newtek Shopping cart, and see something like this, this article explains how to ensure your permissions are set properly so your images display correctly.


Basically, all you need to do is make sure that the "Images" folder where custom logos, images, buttons, etc. are stored has the proper permissions that allow you to "write" to it.

To check this, log into the WebControlCenter using your customer ID and password, and navigate to Site --> File Permissions


Once here, on the tree menu that appears in the main window, navigate to your installation location. If you installed the cart to a sub-folder (in this example the cart is installed in a folder called "newtekcart"), you will want to expand that folder and select the "images" folder.

Once the folder is high-lighted, check to make sure that the "EVERYONE" user has "Write" permissions. As you can see, in this example that user does NOT have the proper permissions to "write" files to the folder.

To fix this problem, click the "Edit" link to the far right and you will see this page appear (however, the checkbox next to "Write" will be empty):

 Check the box in the "Write" column for the "EVERYONE" user. You will also want to place a checkmark in the box next to "Apply permissions to all sub folders/files". Be sure to save the changes. 



Now, you should be able to upload custom logos, images, change themes, and more. If this does NOT fix your problem, please contact Technical Support.

Add Feedback