Changing your PHP version in IIS Manager (Windows 2008/IIS7)

In order to change your site's version of PHP through IIS Manager, you'll first need to have IIS Manager installed on your local machine, and know how to log into your site with it.  For more information on how to do that, please click here.

Once the PHP Manager module for IIS is installed on the server, you should be prompted to install a new assembly when you log into your site via IIS Manager.  Depending on other changes that have been made, or module's that have been added since the last time you logged in with IIS Manager, there may be several more assemblies to install.




Once logged into your site with IIS Manager, you will see the PHP Manager icon under the IIS section. Double-click the icon.




Once inside the PHP Manager, you'll see an option to "Change PHP version."




From the drop down, select the version of PHP. Then click OK.




After changing your version, you can select the "Check phpinfo()" link to be sure it's working.




Your PHP information should display.




For customers reaching this article after receiving a notification that your version of PHP was upgraded from 5.2.13 to 5.2.14: if your site experiences any problem after the upgrade and/or after changing your PHP version back to 5.2.13, you may need to restart your application pool, or contact technical support.

Add Feedback